Back to overview
Downtime
All services down
Jun 29 at 10:18am BST
Affected services
Whitelist(s)
Product API
Resolved
Jun 29 at 03:33pm BST
Services are now back online. Thank you for your patience.
Affected services
Updated
Jun 29 at 12:04pm BST
We have been made aware of the issue and are urgently contacting the relevant people to resolve it.
Affected services
Created
Jun 29 at 10:18am BST
All of our services went down due to a failure in the automatic renewal of our servers. This is because the Lumen Corporation bank account has changed details, and therefore automatic renewal could not occur.
Affected services